Registration - Payment issues
Incident Report for Athlinks
Resolved
This incident has been resolved.
Posted Jul 31, 2019 - 14:36 MDT
Update
We are continuing to monitor for any further issues.
Posted Jul 31, 2019 - 13:19 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2019 - 12:30 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 31, 2019 - 12:15 MDT
Investigating
We are currently investigating an issue with payment processing.
Posted Jul 31, 2019 - 11:59 MDT
This incident affected: ChronoTrack Live (CTLive Registration).